Skip to main content

Steps for exception notifier Ruby -1.9.2 and Rails 2.3.8 For Exception Notifier in rails

Steps for exception notifier

1)ruby script/generate mailer notifier
2) ruby script/plugin install git://github.com/rails/exception_notification.git -r "2-3-stable"
3)lib/notifier.rb to change the ->  @@sender_address = %("Exception Notifier" <xxx@gmail.com>) -> For yahoo only we need to change these line
4)Add these line to  config/environments/development.rb and config/environments/production.rb

config.action_mailer.default_url_options = { :host => 'local host:3000' }
config.action_mailer.delivery_method = :smtp
config.action_mailer.perform_deliveries = true
#for gmail
 ActionMailer::Base.smtp_settings = {
   :address              => "smtp.gmail.com",
   :port                 => "587",
   :domain               => 'gmail.com',
   :authentication       => :login,
   :user_name            => 'xyz@gmail.com',
   :password             => 'xxxxx',
   :enable_starttls_auto => true
 }


#for yahoo mail
 ActionMailer::Base.smtp_settings = {
   :address              => "smtp.mail.yahoo.com",
   :port                 => "25",
   :domain               => 'yahoo.com',
   :authentication       => :login,
   :user_name            => 'xxx@yahoo.co.in',
   :password             => 'xyz',
   :enable_starttls_auto => true
 }

 5)config/environment.rb

 ExceptionNotification::Notifier.email_prefix = "[Application Name - #{RAILS_ENV}]"
ExceptionNotification::Notifier.exception_recipients = %w(test<test@gmail.com>)


6)IN application controller add these line
include ExceptionNotification::Notifiable

7)In controllers rescue block to change the

    rescue StandardError => error
    notify_about_exception(error)

Comments

Popular posts from this blog

Gem::LoadError (Specified 'mysql2' for database adapter, but the gem is not loaded. Add `gem 'mysql2'` to your Gemfile (and ensure its version is at the minimum required by ActiveRecord).?

Gem::LoadError (Specified 'mysql2' for database adapter, but the gem is not loaded. Add `gem 'mysql2'` to your Gemfile (and ensure its version is at the minimum required by ActiveRecord).) In rails?


1)change the gemfile in mysql version
 gem 'mysql2'

2)Change to mysql2 version
 gem 'mysql2','0.3.20'

Active Scaffold : Add radio buttons to your form ruby on rails ?

Active Scaffold : Add radio buttons to your form ruby on rails ?

The way to add radio buttons to your active scaffold create/update from is as shown below

#Controller

class UsersController < ApplicationController
active_scaffold :user do |config|
config.label = “Users”
config.columns = [:name, :gender]
config.columns[:gender].form_ui = :radio
config.columns[:gender].options[:options] = [['Male', '1'], ['Female','2']]
end
end

Get the Current url in ruby on rails

request.refererrequest.fullpathrequest.fullpath.split("?")[0]request.referer or request.env['HTTP_REFERER'] your controller to get the referer url. 

--------------------
request.original_url
request.url
request.host_with_port
<link rel="canonical" href="<%= request.url %>" />
<%=request.path%>
How can I get the current absolute URL in my Ruby on Rails view?
The request.request_uri only returns the relative URL.
request.env['REQUEST_URI']

 For Rails 3.2 or Rails 4 you should use request.original_url to get the current URL. More detail.

For Rails 3: You want "#{request.protocol}#{request.host_with_port}#{request.fullpath}", since request.url is now deprecated.

For Rails 2: You want request.url instead of request.request_uri. This combines the protocol (usually http://) with the host, and request_uri to give you the full address